File Explorer shows a drive with a network mounting point as 'Disconnected'.


Applies To: CBFS Connect, CBFS Storage, CBFS Disk

Problem

A network mounting point is created and accessible, yet File Explorer shows the corresponding drive letter as 'Disconnected'.

Background

CBFS Connect and other products use a Helper DLL to perform a variety of functions, such as updating the Shell with the state of a drive. If a drive is accessible, but File Explorer reports the drive is 'Disconnected', then it is possible the Helper DLL did not properly load into File Explorer.

A closely related situation is that while File Explorer may be displaying the drive correctly, other applications don't - in their File Open/Save dialogs, the drive is displayed as disconnected.

Potential Causes

Steps To Take

The Helper DLL did not load into memory

  • Ensure that the MODULE_HELPER_DLL flag is included when calling the Install method or function. Afterwards, restart File Explorer.

  • Check whether File Explorer loads the helper DLL in memory using SysInternals Process Explorer.

    1. Choose the process (explorer.exe) and in the bottom pane see the list of DLLs.

    2. If the bottom pane is not shown, it should be enabled in the menu, View->Show Lower Pane (mark it), then choose "DLLs" in the View->Lower Pane View submenu.

    3. The list of DLLs should include "cbfsShellHelper24.dll" for CBFS Connect version 2024; for other versions or products, the name will be similar.

  • If the drive is shown as Disconnected only in some application other than File Explorer, the above steps should be applied to the processes of that application.

Issue with NetworkProvider Registry Key

  • Inspect the list of network providers in the registry.

    1. Use RegEdit to go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider.

    2. Look for three subkeys: HwOrder, Order, ProviderOrder.

    3. Verify each subkey has "cbfs24" (CBFS Connect 2024) or the string matching your product and version.

    4. If missing, manually add the string to the registry and restart explorer.

Always remember that the specific problem you encounter may have a different cause or require a different solution than those listed above.

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